Скрипт выключения подсветки на Mikrotik кнопкой

Данный скрипт позволяет выключить всю подсветку индикации на устройствах Mikrotik по нажатию кнопки на корпусе (обычно MODE, но можете забить на любую). Ну и включить назад повторным нажатием.

Требуется исполнить следующее полотно в командной строке Mikrotik:

/system script
add comment=dark-mode dont-require-permissions=yes name=dark-mode  policy=\
    ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source="\r\
    \n   :if ([system leds settings get all-leds-off] = \"never\") do={\r\
    \n     /system leds settings set all-leds-off=immediate \r\
    \n   } else={\r\
    \n     /system leds settings set all-leds-off=never \r\
    \n   }\r\
    \n "
/system routerboard mode-button
set enabled=yes on-event="system script run dark-mode"

Это добавит новый скрипт с содержимым в скрипты, а также создаст функцию для кнопки MODE, которая вызывает этот самый скрипт. Проверено на cAP ac.